python升级引起的pip执行错误

Linux下python 2.6升级到2.7后,pip执行出错,错误信息:

# pip
Traceback (most recent call last):
  File "/usr/bin/pip", line 5, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named pkg_resources

这是因为pip需要升级到配套的版本。

Continue reading “python升级引起的pip执行错误”